1. Are you ready for the Galaxy S20? Here is everything we know so far!

3.5mm headphone problems

Discussion in 'Android Devices' started by n8wood, Jan 10, 2010.

  1. n8wood

    n8wood Lurker
    Thread Starter

    Sometimes when I plug in a headphone cable into my n1 if I touch the plug it skips to the next song and pauses immediately. It seems like only certain cables do this but none of these cables give me problems with my other mp3 players or my iPhone. I'm thinking of returning it for a replacement but I'm wondering if anyone else is having similar. problems.

  2. 3rd-Geer

    3rd-Geer Android Enthusiast

    Are you using the new N1 headphones? Here is something interesting I learned. When I got my UK HTC Hero back in June, they came with the same headphones as the N1. At the time I lost my iphone headphones, so I started using the Hero headphones in my iphone. After a couple days I started having the same problems as you except on my iphone. If I would touch the chord it would skip tracks or pause the music. When I used the headphones in my Hero, it would work fine. It actually made me go in to an apple store and they plugged in other headphones and to my surprise it worked fine.

    So.....what I learned is that for some odd reason the headphones used in my HTC Hero would screw up if I used them with my iphone.

    Might just be something about the difference in the two....I'd say test your N1 out with a different pair of headphones.
  3. n8wood

    n8wood Lurker
    Thread Starter

    Thats interesting.

    My experience is a bit different. I am plugging in generic 3.5mm cables to connect to external speakers and a car radio. The cables only have two contacts instead of the three found on the headphones. The weird thing is, some cables work fine and some others are problematic.

    I called HTC today and they made me do a factory reset. Will try testing later today, hopefully I don't have to send it back.
  4. n8wood

    n8wood Lurker
    Thread Starter

    Just following up on this. The factory reset seems to have resolved the problem.
  5. elyhero

    elyhero Lurker

    I had simililar symptoms using Spotify. Tracks would skip forwards or backwards seemingly randomly. Finally figured out tonight it didn't happen with loudspeaker, only with headphones.

    I had switched the headphones that came with the phone with an alternate pair with a 3.5mm jack, this was the problem. Use the phones that come with the phone and the problem went away.

    For further technical reasons why .... read on ... for a fix skip to the end ...

    Reason is, the headphones supplied have 4 connectors (or poles) on the jack. Look closely and you can count three black plastic rings that separate the different areas. This is a TRRS design rather than TRS design and is the same as the iPhone, but not the iPod.

    The first two connectors are audio L&R, the third is the ground, and the fourth is for the microphone. However, the fourth connector is also used for the remote control - the skip and pause buttons that are on the wire.

    The Hero is listed as having a standard 3.5mm jack, and this is true, but if your 3rd party earphones or audio cable has only two black rings (like 99% of stereo cables!) the slightest touch may cause a connection between the mic and ground connector, which seems to the phone like you are pressing the remote buttons - and the result is annoying and random skipping.

    The reason some cables and some don't depends on the length of the ground connector on the plug, this isn't the "business end" so it isn't standard.

    A workaround is a product like this:

    Zooinc Audio Converting Cable for Apple iPhone: Amazon.co.uk: Electronics & Photo
    or this:
    Brand New 3.5mm to 3.5mm Jack Stereo Headphone Audio: Amazon.co.uk: Electronics & Photo

    These have a 4 ring plug, and a 3 ring socket, so they will make normal headphones "safe" to go into your phone.

    Given that this problem must affect iphones and presumably a bunch of other smartphones I'm amazed there isn't more on the web about it!
  6. Teknologic

    Teknologic Android Expert

    Thanks for identifying the problem. I have this when I'm using bTunes to play some music in my car and the slightest movement will activate the stock music player and skip through some songs and thus have 2 songs playing through my speakers.
    It's scary and annoying enough to make me crash into a tree o_O
  7. Roze

    Roze Hiding behind a mystery

    oh dear >_> hope the damage wasn't substantial...

    I have a question with regards to the stock earphones. Where is the mic on the damn thing? I've been using it for a couple of days now and all of my friends have been complaining that they are unable to hear me clearly :mad:. I tried holding the remote button thing closer to me...but that didn't really work, and I even tried talking into my phone! lol...which I felt was beside the point.

  8. SBERG

    SBERG Member

    If im right its on the back of it. Look and youll see a small hole on the back so i assume thats it. lol hope that helps.
  9. Roze

    Roze Hiding behind a mystery

    Alright...I see it >_> now who the heck would put the damn mic at the back of the controller!!! I mean you attach the damn thing onto your shirt with the buttons facing outward...which means...the mic is insulated by your clothes : < Is it me...or does this feel like a design flaw :/

    Thanks SBERG :)
  10. Teknologic

    Teknologic Android Expert

    Well there were no trees around at the time so that old lady didn't really ding up my car too hard :D
  11. Roze

    Roze Hiding behind a mystery

    It's ALWAYS the old lady!!!! ;)
  12. worker1

    worker1 Member

    Thanks for identifying the problem guys: It was skipping tracks even when the phone was locked, but when I was touching it, I was thinking wtf.
  13. worker1

    worker1 Member

    Is there any other way to fix this other than to buy an adapter?
  14. worker1

    worker1 Member

    I found a solution: meridian player pioneer allows for disabling of headphone controls. I am using that. I like it, and it's free.
    Some people have said that just installing meridian helps correct the problem; there's another "m" titled media player that disables headphone controls also, but I don't remember the name.

    edit: don't do a barcode scan off of the web; it goes to some classic version that is out of date. search for meridian in the marketplace.
  15. Teknologic

    Teknologic Android Expert

    Using another media player isnt a solution for me, whenever the problem occurs it just switches on the stock media player and I basically have 2 playlists playing at the dame time. The only option for me besides the connector plug would be to root and uninstall the default media player.. i think.
  16. Roze

    Roze Hiding behind a mystery

    hmm...I thought we can >_> but just checked the system and we can't :/ Oh man...that sucks :mad:
  17. worker1

    worker1 Member

    what if you use a task killer to end the music player so it isn't listening for headset controls?
  18. worker1

    worker1 Member

    taskkill doesn't work. I downloaded a one second silent mp3 and made a playlist with only that file in it. I played the playlist and exited the music app. When the music app starts it will play one sec off silence and stop. For the time being, problem solved. Otherwise, I could have rooted and removed the music app.
  19. Teknologic

    Teknologic Android Expert

    Hey good thinking, very original and pretty simple solution.
    Gonna try it.

Nexus One Forum

The Nexus One release date was January 2010. Features and Specs include a 1400mAh battery, 3.7" inch screen, 5MP camera, 512GB RAM, and Snapdragon S1 processor.

January 2010
Release Date

Share This Page