1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ROOT] One-click root for LG Lucid :: 4/18/12

Discussion in 'Android Devices' started by k0nane, Apr 18, 2012.

  1. k0nane

    k0nane Android Expert
    Thread Starter

    k0nane, Shabbypenguin, and bliss present...
    One Click Root for LG Lucid


    Hi folks. Your phone's basically a rebadged Connect. It can be rooted the same way. So we didn't actually have to do anything! This would have been out sooner if you folks had responded to our "come test with us" almost a month ago... ;) The talented Dan Rosenberg already rooted the LG Spectrum (see here) and was kind enough to post a one-click for Windows and OS X/Linux. Myself and Shabbypenguin don't have much to add - it works, Mr. Rosenberg (bliss/@djrbliss) did all the work, you all have him to thank.

    But, without further ado...

    How to Install

    Your device must be in USB Debugging mode. To turn it on, go to Settings > Applications > Development and check the box.

    Linux/Mac: Connect your device to your PC, unpack the archive, and run run.sh. You may need to chmod 755 run.sh.

    Windows: Install the LG Spectrum USB drivers (download), unpack the archive, and open run.bat.

    We do not use file hosts with waiting times or CAPTCHAs!

    Windows Download (Direct) | Mirrors :: Direct #2
    Linux/Mac Download (Direct) | Mirrors :: Direct #2


    • Dan Rosenberg: security researcher, rooter, friend of the Hit Squad, did all the work
    • markolo25: locating working drivers
    • Shabbypenguin: Shabbypenguin

    Don't forget to join us in the IRC channel! If you want to donate, donate to the EFF, Red Cross, or Mr. Rosenberg.

    goonsage, joezack, bkrahmer and 2 others like this.

    1. Download the Forums for Android™ app!


  2. k0nane

    k0nane Android Expert
    Thread Starter

    P-O-S-T :: R-E-S-E-R-V-E-D


    Original artwork by Pendulum via Gasolin3.

    ...for future use.

    Follow me on Twitter @k0nane and @publik0!
    Follow Dan Rosenberg on Twitter @djrbliss!
    Bloobs likes this.
  3. Shabbypenguin

    Shabbypenguin Extreme Android User


  4. munkyshet

    munkyshet Lurker

    Love you all <333
  5. munkyshet

    munkyshet Lurker

    shit, we have a problem officer. Stuck on "waiting for device."
  6. blumeany

    blumeany Well-Known Member

    I got past 'waiting for device' initially, but it stopped a few steps later. Ended up trying to run it a couple times again, but got stuck at 'waiting for device' each time. Ended up leaving the 'waiting for device' message up while leaving the phone connected and restarting the phone. Did a couple reboots and then progressed to the root.

    Just installed ROM Manager, so it looks like superuser is working. (Although there doesn't appear to be a Clockwork recovery for our phone model?)
  7. blumeany

    blumeany Well-Known Member

    Aw crap. Was screwing around trying to install a version of clockwork mod recovery and now the phone's loopin' :p
  8. Shabbypenguin

    Shabbypenguin Extreme Android User

    rom manager = bad mkay.
  9. blumeany

    blumeany Well-Known Member

    Lol. Any thoughts on getting this mofo working again, outside of a wipe?
  10. trimax84

    trimax84 Lurker

    Just got this phone today. Glad to see an easy method for root is out.
    Had to troubleshoot a little; tried rooting before the system update to no avail. (I did end up updating....probably didn't matter though).

    To get it to work, I followed the above instructions and when the command prompt said "waiting for device" I rebooted the phone. It then went through all the steps including several reboots and now I have root :)

    Thanks :)
  11. blumeany

    blumeany Well-Known Member

    A lesson to all you youngsters out there: DON'T INSTALL ROM MANAGER AND CLOCKWORK MOD! ;)

    Had to order a replacement and go back to my old phone for a while (phone is backordered again. must be popular). Ah well, live and learn. :cool:
  12. Shabbypenguin

    Shabbypenguin Extreme Android User

    sorry :/

    we need to get virgin dumps of this device, so if someone isnt rooted could get em that would be awesome
  13. cpupeli1

    cpupeli1 Well-Known Member

    I cannot click USB debugging unless the USB is unplugged, after its plugged in it greys out, either way I ran the run.bat and its staying at "waiting for device"

    any thoughts?

    **EDIT** I rebooted while it was "waiting for device" and now I have root, thanks again.
  14. windscape

    windscape Newbie

    My LG Lucid was delivered today is currently at home still in the UPS box. I should be home in about an hour, but not sure when I'll get time away from the wife to use the new phone.

    If there is a somewhat easy process to get a virgin dump from the device that works in Linux (my preferred OS and the only one on my preferred home PC), I would be happy to provide a virgin dump. I'd also like to know the preferred file host to upload it to.
  15. Shabbypenguin

    Shabbypenguin Extreme Android User

  16. windscape

    windscape Newbie

    The dump didn't work, although I think root did. Here is the output: [root@twin-rockets spectrum_root_linux_osx]# ./run.sh ./run.sh: line 22: [: too - Pastebin.com

    This was done on Arch Linux 64-bit using the adb binary from the android-sdk-platform-tools r11-1 AUR package.

    I've used up my allotted time away from the wife tonight, plus I'd like to use my new phone, so another dump attempt will have to wait.
  17. Shabbypenguin

    Shabbypenguin Extreme Android User

    bah im an idiot, forgot shell in front of the command, anyways wont much matter, your system is now tainted with root :p

    need someone else now that i fixed teh scripts :/
  18. MoogDiesel

    MoogDiesel Lurker

    I used the scripts and it rooted successfully, but where is the dump?
  19. slyswine

    slyswine Lurker

    For the newly posted root/dump scripts, will the linux version work with OSX? I don't have a windows pc at the moment. Thanks
  20. Shabbypenguin

    Shabbypenguin Extreme Android User

    should appear in the one click folder, if not then they are on your sdcard
  21. stevis22

    stevis22 Lurker

    Has anyone gotten tethering to work on the lg lucid? Using a rooted lucid, I have barnacle installed, and can get clients to connect, but can't download any actual data. Is vzw blocking this somehow?
  22. commbubba19

    commbubba19 Newbie

    Is there any way to confirm being rooted beyond the CLI saying it's complete?

    So far I haven't found any benefit to being rooted and I can't uninstall any bloatware without paying for an app to uninstall apps from the system folder.

    edit: I realized that superuser gets installed and after installing titanium backup I was able to uninstall bloatware.
  23. saxydroid

    saxydroid Newbie

    Since this is a rebaged Connect 4G, will mods from the connect (ie Kernels, CWM, Roms) if and when available work, if not what will need to be done to make them work.
    I assume roms from the connect may need something to make them work on verizon's network.
  24. Shabbypenguin

    Shabbypenguin Extreme Android User

    roms wont work, kernels if any changes need to be made will be minimal, expect more stuff from the lg viper tho it is sprints first lte phone so i imagine it will get more attention then the lucid or connect
    Bloobs likes this.
  25. umadcauseubad

    umadcauseubad Lurker

    guys one thing I learned when trying to root is your phone has to be set to internet (modem/ethernet) for the USB debugging to work. Once I did this the root went flawless
    moserine, Bloobs and xmr405o like this.

LG Connect 4G Forum

The LG Connect 4G release date was February 2012. Features and Specs include a 4.0" inch screen, 5MP camera, 1GB RAM, Snapdragon S3 processor, and 1540mAh battery.

February 2012
Release Date
Similar Threads - ROOT click root
  1. Lollypolly
  2. Teofel Ervenge
  3. LA1
  4. Troubleshooter03
  5. Teofel Ervenge
  6. kylabeardad
  7. DopeSaladz
  8. EvasiveEmanual
  9. SpanDragon18
  10. Sunny Rio

Share This Page