1. Download our Official Android App: Forums for Android!

Support Wireless N

Discussion in 'Android Devices' started by hilmar2k, Jul 5, 2011.

  1. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    I can't seem to connect to my router via wireless N, only G. I don't see any options on the phone to enable/disable wireless N.

    Am I missing something?
     

    Advertisement

  2. seejoshplay

    seejoshplay Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    131
    Joined:
    May 3, 2011

    May 3, 2011
    131
    8
    36
    Dunno, the thing has a b/g/n card...maybe email HTC? Their customer people WILL reply to your email in 24hrs
     
  3. bpf

    bpf Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jul 4, 2011

    Jul 4, 2011
    6
    3
    6
    A bit of a long shot, but be sure your router is set to either dual-band "N" (2.4GHz/5GHz) or 2.4GHz only. Mine was set to 5GHz only (less interference) and the Dinc2 couldn't connect. As soon as I enabled 2.4GHz it worked. I'm guessing the phone doesn't support the full 802.11n spec.
     
  4. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    I have both bands set for b/g/n.
     
  5. amarryat

    amarryat Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    365
    Joined:
    Apr 18, 2010

    Apr 18, 2010
    365
    41
    43
    MA
    How do you know it was connected via G?

    When you check the connection status, if it is connected at anything above 54, then it's not G. It definitely works fine with my Netgear WNDR3700.

    It is true, the phone only supports the 2.4GHz band.
     
  6. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    My router shows it as connected via G, and the phone reports a connection speed of 54Mbps.
     
  7. amarryat

    amarryat Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    365
    Joined:
    Apr 18, 2010

    Apr 18, 2010
    365
    41
    43
    MA
    I wonder if any of the neighbor friendly stuff that N has is causing this. Is the router set to its defaults as far as those settings are concerned?

    Is there a way to restrict to N only (for testing purposes), and then see what happens when you try to connect?
     
  8. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    I was going to set it at N only last night to test, but realized the laptop I was using at that very moment was G only, so I would have lost connection to the router. I'll need to hard wire to the router to make that change for testing purposes.

    At the end of the day, this doesn't really matter. 54Mbps is way fatser than the data speeds being sent over wifi. Even after the loss due to overhead, wireless G is still 15-20Mbps, which is significantly faster than any internet connection that is being used by my phone. I guess I just want it to work as advertised.
     
  9. amarryat

    amarryat Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    365
    Joined:
    Apr 18, 2010

    Apr 18, 2010
    365
    41
    43
    MA
    It must be a setting in the router that is causing it to be unable to connect via N. Have you ever verified that another N capable device has successfully connected to that router via N?
     
  10. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    Yes, though that may have been at 5GHz, not 2.4. I *think* my wife's netbook is N, so I can check that tonight.
     
  11. amarryat

    amarryat Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    365
    Joined:
    Apr 18, 2010

    Apr 18, 2010
    365
    41
    43
    MA
    To reduce confusion, i would keep the names of the two ssid's different when you do your test.
     
  12. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    They are currently unique.
     
  13. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    Problem solved. Switching from WEP to WPA2 corrected the issue.
     
  14. bpf

    bpf Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jul 4, 2011

    Jul 4, 2011
    6
    3
    6
    Glad it's working. And of course, using WEP is like having no security at all so you're much better off this way.
     
  15. hilmar2k

    hilmar2k Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,369
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1,369
    293
    163
    New York
    Yeah, when I first got wireless, WEP was all there was. It was just easier to set up each new router with the same security than to change it in every device that accesses the network. I completely forgot that WEP and N didn't play well together.

    Guess it was about time to update to real security.
     
  16. alarinn

    alarinn Newbie
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Jul 22, 2011

    Jul 22, 2011
    10
    1
    16
    Ok I have this issue too. I bought an ASUS RT56U router in place of my linksys 610n and when the 2.4 band is set to n-only, the phone doesn't see it. My laptops all connect to it fine at the 801.11n setting. The same thing happened to the 610n router. If I set my 610n to b/g, the phone connects fine. I also turned the 610n off so it doesn't conflict with the ASUS. This phone has no wireless-n support and it has the 2.3.4 software version on it. What a ripoff.

    Yep confirmed that this phone doesn't support wireless n. I have an old laptop that is a/b/g and it doesn't see it also although it connects to the n-only 5GHz band fine. The other laptops that are weeks old connect to the 2.4GHz n-only band fine. This phone sees not a single band on either 2 routers other than the 2.4GHz b/g band on the 610N. So what I did is connect the 610N to the ASUS and I have my McGyver'd version of a dual band router:) And yes, all of the bands have unique SSIDs and all are not hidden. For some reason this HTC Inc2 can't see any of the n bands.
     
  17. mihneagabriel

    mihneagabriel Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    110
    Joined:
    Jun 2, 2010

    Jun 2, 2010
    110
    12
    38
    To use the N band you can't use WEP.. My router won't even allow it
     

Share This Page

Loading...