1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

[NEW SuperOneClick] Root, Install & Use xRecovery on Xperia X8


Last Updated:

  1. massiliafrog

    massiliafrog New Member

    Joined:
    May 15, 2011
    Messages:
    4
    Likes Received:
    0
    i've been under linux all day long for years now...
    it still incredible to me that i should have windows to make linux stuff work!
     

    Advertisement
  2. uzumizan

    uzumizan New Member

    Joined:
    May 26, 2011
    Messages:
    3
    Likes Received:
    0
    i try it to paste it 3 times and i shutdown and reboot and press back key multiple times but nothing happen please help me???? reply A.S.A.P
     
  3. gabeyong

    gabeyong Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    725
    Likes Received:
    288
    Hi,

    there is another way but it has prerequisites.

    Have a look here

    cheers :)
     
  4. uzumizan

    uzumizan New Member

    Joined:
    May 26, 2011
    Messages:
    3
    Likes Received:
    0
    i do all the step but nothing happen??? i am newbie
     
  5. gabeyong

    gabeyong Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    725
    Likes Received:
    288
    dude...

    there is a youtube video at the first page. watch the video and follow step by step.

    cheers :)
     
  6. tiong

    tiong Member

    Joined:
    Jun 1, 2011
    Messages:
    6
    Likes Received:
    0
    i cant COPY ALL THE 3 FILES (one by one) FROM xRecovery Folder to </system/bin> folder
    (i.e. busybox, chargemon and xrecovery.tar)

    and pop up say no enought place??? what shloud i do?
     
  7. gabeyong

    gabeyong Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    725
    Likes Received:
    288
    Hi,

    too much games or apps installed in your phone.
    you need to create space by removing apps or games from your phone.

    cheers :)
     
  8. uzumizan

    uzumizan New Member

    Joined:
    May 26, 2011
    Messages:
    3
    Likes Received:
    0
    i followed the step by step but xrecovery menu don't show up???? why??? should i hard reset m phone???
     
  9. evil nemesis

    evil nemesis Member

    Joined:
    Jun 4, 2011
    Messages:
    13
    Likes Received:
    1
    awesome worked like a charm, thanks alot
     
  10. ulau

    ulau New Member

    Joined:
    Jun 6, 2011
    Messages:
    1
    Likes Received:
    0
    Hi gabeyong, can u help me out....

    I have problem copying 3 xRecovery files to /system/bin because i cannot use my root explorer, it keep saying that my root explorer have issues with superuser app, i keep restarting this app but it still not work...
     
  11. gabeyong

    gabeyong Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    725
    Likes Received:
    288
    hi,

    uninstall and re-install root explorer
    when you launch root explorer the next time you must give the root explorer app root access make sure you <enable><remember> then <allow> so it will always give root explorer access.

    cheers :)


    [​IMG]
     
  12. suren8702

    suren8702 Member

    Joined:
    Jun 5, 2011
    Messages:
    5
    Likes Received:
    0
    Flashed my X8 twice this week.. Hehe :-D
     
  13. AniK

    AniK New Member

    Joined:
    Dec 11, 2010
    Messages:
    4
    Likes Received:
    0
    Gabeyong, THANX A MILLION. GINGERBREAD 2.3 is supercool stable & very fast on X8. I almost resold off this phone within 3 months of buying as I was frustrated with lack of Market access and Eclair.
    SE are #$#? X8 with Donut or Eclair is like Lada engine in a Sportscar.

    But last week took courage and rooted my X8. Yesterday after many unsuccessful attempts at xrecovery boot up I'm the proud owner of an X8 running Gingerbread 2.3.
    ENTER AT YOUR OWN RISK But you can't fail if you wont even try.

    Thanks to many posts of blessed souls like yourself and others on XDA and Youtube. Glad to help out any poor souls who were suffering like I did over past 5 months.
     
  14. ExHaUsTeD

    ExHaUsTeD New Member

    Joined:
    Jun 22, 2011
    Messages:
    4
    Likes Received:
    0
    after I start to root explorer, "Restart app" will come out,I tried and tried again but the same thing out,what exactly the prob..plz help me...
     
  15. ExHaUsTeD

    ExHaUsTeD New Member

    Joined:
    Jun 22, 2011
    Messages:
    4
    Likes Received:
    0
    i have already done installing that root explorer,but when i running it, it always say "Restart app"n the superuser request doesn't come out....i try again and again, but the result still same...i realy need help from anyone who can help..plzz....
     
  16. ExHaUsTeD

    ExHaUsTeD New Member

    Joined:
    Jun 22, 2011
    Messages:
    4
    Likes Received:
    0
    i have already clicking on super user,but no apps in list....how is it???
     
  17. metalblade

    metalblade New Member

    Joined:
    Jul 3, 2011
    Messages:
    1
    Likes Received:
    0
    all of you who rooted ur device, i believe you observed that u are prompted to install busybox. can anyone tell, What does it do exactly, for me, as a user? if i uninstall it, do i lose root priveleges? i know it is used by developers for "developing"... im not creating anything, nor writing codes. busybox verified if my device is rooted and since then it just ...sits.
     
  18. gabeyong

    gabeyong Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    725
    Likes Received:
    288
    busybox is required for xRecovery to work... if you remove or uninstall it xrecovery will stop working but root remains.

    cheers :)
     
  19. brigibrigdale

    brigibrigdale New Member

    Joined:
    Jun 27, 2011
    Messages:
    1
    Likes Received:
    0
    can anybody help my please i downloaded the x8 drivers but i dont know how to install them on my windows 7 pc i tried using super one click without the drivers but it just stays on waiting for device and says its not responding i would much appreciate it if somebody would help me :)
     
  20. gabeyong

    gabeyong Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    725
    Likes Received:
    288
    Just install PC Companion for your X8 and the required drivers will be installed together with the software.

    download from here

    cheers :)
    gabe
     
  21. duncanidahoe

    duncanidahoe New Member

    Joined:
    Jul 22, 2011
    Messages:
    2
    Likes Received:
    0


    This was posted earlier in this thread, but I will just add it again. I had problems with my Windows 7 64 bit PC rooting this phone I had to do it from my XP 32 bit pc to get it to work. The driver for the phone for windows 7 is on it, it just won't work properly on a 64 bit system. Someone had suggested that the version of Java was the problem, but as I am testing 32 bit versions of Firefox I have both the 32 and 64 bit versions installed. Best bet find someone with a 32 bit computer and do it from there.
     
  22. duncanidahoe

    duncanidahoe New Member

    Joined:
    Jul 22, 2011
    Messages:
    2
    Likes Received:
    0
    Now I'm having a problem getting into xRecovery. All the files are where they are supposed to be everything is working like it's supposed to except that when I turn the phone on and press the back button repeatedly the phone just continues to boot. Been back to the system/bin folder several times the files that are supposed to be there are there. Any suggestions?

    Never mind recopied the files again and everything is working now. Thanks to all involved in the posts and development of the OS!!!!!
     
  23. Gakky95

    Gakky95 New Member

    Joined:
    Feb 19, 2011
    Messages:
    2
    Likes Received:
    0
    how do you copy the files from xrecovery to system/bin?? i used the astro thingy and when i go to the system/bin it can't be pasted!!!! help :mad:
     
  24. gabeyong

    gabeyong Well-Known Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    725
    Likes Received:
    288
    Hi,

    you need to root your phone and install Root Explorer then enable read/write then copy and paste the xrecovery files to your /system/bin

    cheers :)
    gabeyong
     
  25. gaogao6

    gaogao6 Member

    Joined:
    Aug 1, 2011
    Messages:
    5
    Likes Received:
    0
    Hi ,first of all thaks for sharing

    I having problem when rooting my x8
    my superoneclick show "not responding"

    can you help??
    and what happen is that??
     

Share This Page

Loading...