Wi-Fi issueSupport


Last Updated: 2015-05-27 17:45:19
  1. Travisimo

    Travisimo Well-Known Member

    I have a Verizon GS4 and a Netgear R6300 router. I was having one of the problem mentioned here where it shows it was connected via WIFI with a strong signal, but download speeds were very slow (like dialup speeds). My router in dual-band and I was connecting at 5G frequency. When I connected to the other band, it has worked perfectly fine ever since. I tried other channels and such, but nothing else seemed to help.

    Advertisement
  2. rcyphermd

    rcyphermd Well-Known Member

    Do you notice any difference in your voice or signal quality between the note 2 and the s4?
  3. speedlever

    speedlever Well-Known Member

    Speaking for myself, while I had the GN2 for less than 10 days, I haven't noticed any difference between the GN2 and the GS4 on those issues. If they exist, they are too subtle for me to pick up. But I've been in the GS4 for several weeks now, so those differences, if there were any, could well be masked at this point.
  4. brasco901

    brasco901 Member

    Wifi not working on Belkin router either. Anybody else having problems with the Belkin brand? I've checked for firmware upgrades and it's on the latest firmware. I've got my ssid setup as wpa and it fails on obtaining ip address over and over again. If i remove the security it connects just fine. when i set it up as wep...same thing happened....failed to obtain ip address. Is samsung ever going to address/fix the wifi issues it has with the s4? Also....I can connect to other wireless networks that are non belkin or d-link branded just fine.
  5. 1sved1

    1sved1 Active Member

    Fellow S4 wifi sufferers - I have done a lot of searching on this and found it is not just a Galaxy or Samsung problem (a lot of angry Droid and HTC users out there with this prob also) It sems to have cropped up when Jellybean was updated (I believe it was 4.1.2? Would have to go read the posts again) and it seems to be related to the AGE of your router. I had a DLink 635 from 2006 - they stopped supporting it in 2010. Everything works BUT my S4 and I work from home, so I need it to work here. After researching it (Google Jellybean wifi issues to see for yourself) I decided to go out an buy a new router - found a list of SUPPORTED ROUTERS (below) and got a NetGear N600 and now have fantastic connection to wifi. Still run into the problem at the occasional restaurant or coffeshop. If your router is more than 5 yrs old, first update the firmware. If that doesn't do it, then look at the list below and start shopping around. Or wait for Google to fix it (I might not live that long) Note on the list - the "unsupported routers" appear to be the tpye that a service provider would install in your home and the "supported" ones are mostly ones you or I would buy.

    Hope this helps (Hmmm -now if everyone in public places would just upgrade their routers...)

    Here is a list but not limited to the unsupported routers that will not work with the Jelly Bean update
    Unsupported [COLOR=#812528 !important][COLOR=#812528 !important]Routers[/COLOR][/COLOR]
    Router Make/Model Technology
    Westell VersaLink 327W DSL
    Actiontec GT724-WG DSL
    [COLOR=#812528 !important][COLOR=#812528 !important]Netgear[/COLOR][/COLOR] DG834GT DSL
    Netgear DG934G (Sky Version) DSL
    [COLOR=#812528 !important][COLOR=#812528 !important]Linksys[/COLOR][/COLOR] WRPT54G DSL
    Motorola Netopia 3347-02 DSL
    Siemens gigaset SE567 DSL
    Actiontec GT701-WG DSL




    Working Models that work with the Jelly Bean Update, for Wi-Fi

    Router Brand [COLOR=#812528 !important][COLOR=#812528 !important]Router [COLOR=#812528 !important]Model[/COLOR][/COLOR][/COLOR] Notes Router Brand Router Model Notes
    Actiontec GT704-WR . . Linksys e1500 .
    Amped Wireless AP 300 . . Linksys e3000 .
    Apple Airport . . Linksys EA2700 N600 Dual-Band
    Apple Airport Extreme . . Linksys wrt54g .
    Apple Airport Extreme (2.4 GHz) . . Linksys WRT54GL .
    Asus rt-n56u . . Linksys WRT54GS .
    Belkin F7D22301 . . Linksys WRT54GS .
    Belkin F5D7230-4 802.11g 2.4GHz . Linksys WRT54GS v.2 Wireless-G
    Belkin F7D22301 . . Linksys WRT600N .
    Belkin F7D4302 . . Medialink MWN-WAPR150N .
    Belkin N600 . . Netgear WGR614 .
    Belkin R5D7230-4 2.4GHz G router . Netgear DG934G .
    Belkin Surf f7d2301 v1 . . Netgear JWNR2000 .
    Buffalo WHR-HP-G300N . . Netgear N600 .
    Cisco WAP4410N . . Netgear N900 (WNDR4500) .
    Cisco WAP4410N . . Netgear WGR614 .
    Cisco WAP4410N . . Netgear WGR614 .
    Cisco WRT160N . . Netgear WGR614 54 MBps G router
    Cisco WRT160N . . Netgear Wireless-N 150 .
    Cisco WRV210 . . Netgear wnr1000 v3 .
    Cisco WRV210 . . Netgear wnr2000 .
    Cisco Linksys BEFSR41 . . Netgear WNR2000 .
    Cisco Linksys E3000 . . Netgear wnr3500 .
    Cisco Linksys WRT120N . . Netgear wpn824 v2 .
    DLink di-524 . . Ruckus AP .
    DLink dir-605l . . Ruckus VF2825 .
    DLink DIR-615 . . [COLOR=#812528 !important][COLOR=#812528 !important]TRENDnet[/COLOR][/COLOR] TEW-731BR .
    DLink dir-615 . . US Robotics 5461 MAXg Router .
    DLink DIR-615 . . wireless-n router .
    DLink dir-625 . . Zuni Connect .
    DLink dir-628 . . . . .
    DLink DIR-826L . . . . .
    DLink tm-g5240 . . . . .
    SanDee likes this.
  6. 1sved1

    1sved1 Active Member

  7. DDave

    DDave Well-Known Member

    If you had a previous "android / google" device, I think all that information is kept at google.

    I use a Droid Bionic and then bought a Nexus tablet. When I set it up at work I didnt give it much thought, connected it to the network (during setup). But when I got home, it already knew my router and password. HOW CONVIENENT... until I realized that it had ALL of my wifi connections listed.. NOW ITS SCARY!..
  8. BigRedGonzo

    BigRedGonzo Well-Known Member

    At home I have a Linksys EA4500 (don't quote me on that) and at work we have a Cisco Wireless system all over the building. I got my S4 about two weeks ago on Verizon's roll-out day. I had problems connecting to the WiFi at work and at home. It would connect, disconnect, connect, disconnect... for several minutes before finally connecting (or not.) I was ready to return it and get another unit, but decided to do a factory reset (from the recovery menu) because I knew they would try that at the store. After rebooting and getting everything set up, I have had zero issues connecting to WiFi. It jumps right on both systems immediately and stays there. The WiFi at home is lightening fast and the one at work is as fast as that system ever is. Maybe we should stop referring to a Factory Reset as "like right out of the box" because right out the box for me wasn't good. I hope this helps someone.

    BigRedGonzo
  9. Guruware

    Guruware New Member

    After a thorough investigation I found that Comcast customers with a gateway (Modem, Phone, router and wireless all in one) model TG862G for sure (other models may be involved). This gateway has issues with several wireless cards. Initially it was thought that issues were only with Ralink WiFi cards however problems have come up with Mac Book Pro and Samsung Galaxy S4 among others. The issue didn't exist initially but after an automated firmware "upgrade" from Comcast the problems appeared. The two solution Comcast has is to replace you Gateway for another gateway (DO NOT TAKE THIS ONE, same problem will come back); the second is to replace the gateway for a plain modem or EMTA ( modem with telephone service). Since Comcast doesn't offer wireless routers anymore any way you have to buy your own (I recommend this route since you control the type of router you will use). Love it of Hate it this is the reality. Good luck guys!
  10. BigBen213

    BigBen213 New Member

    I've had a similar issue as mentioned earlier in which the Wifi runs slower on the phone than the network. Normally I would just turn off Wifi, but a new problem arose within the past couple of hours in which Wifi won't turn itself off. After a minute or so, it will automatically reconnect with my Wifi even after turning off. I tried restarting, powering down and powering off, and even forgetting my Wifi connection. It still did the same thing, but would just ask for the prompt for my Wifi password. Anyone ever hear of this issue before?
  11. Canesfan

    Canesfan Well-Known Member

    Aha...I described this very issue in my prior posts. The phone's WiFi has a mind of it's own. This continues to be a very big problem for this phone and for Samsung....therefore, a problem for the owner.
  12. speedlever

    speedlever Well-Known Member

    Have you guys done anything to your phones at all? Bone stock all around?

    The only change I've made is to run Nova Prime and disabled a bunch of stock bloatware. My wifi is controlled by command. It has no mind of its own at all. I toggle it on or off as desired (I generally leave it on all the time), I just tested it and it operated as expected... off on command... then back on and connected on command.
  13. Canesfan

    Canesfan Well-Known Member

    Just spoke to Samsung support about my 6 wk. old G4 with continued WiFi problems.

    After jumping thu the hoops of waiting on "hold", then popping the battery and giving them the appropriate serial numbers, I talked to a rep. who talked me thru various things that I already tried, then transfered me to level II support to someone I spoke to for 15-20' and re-described the problems I've been having with WiFi (which have worsened lately). Essentially, he couldn't do anything for me and told me it was up to ATT to replace the device.

    CONCLUSIONS: Samsung has a real (software or other) problem with this phone, Samsung's customer service leaves much to be desired, and I want my iPhone back!
  14. trparky

    trparky Well-Known Member

    Are there any settings in your routers for IPv6? If there is, go to those settings and disable IPv6 in your routers.

    I had the same issue on my Linksys e3200 where it would connect but I wouldn't be able to download anything. I disabled IPv6 and it fixed it.
  15. PickPatrick

    PickPatrick Active Member

    Had a great experience with a VZ tech support last night. She offerred a work around for this wi-fi issue until Samsung updates....... it worked for me so I wanted to share. Caller ID, if removed completely, will eliminate the problem for many. To accomplish this....settings > More > Application Manager>All (on the horizontal bar to the far right at the top)>Caller ID>Force Stop>Uninstall and reboot the phone. Hope this works for others!!!
  16. Canesfan

    Canesfan Well-Known Member

    I have AT&T, but what specifically with the WiFi issue has this remedy helped you with?
  17. PickPatrick

    PickPatrick Active Member

    Canesfan: This fix corrected the wi-fi issue with my d-link router being dropped after the s4 connects at home and then the s4 continally searches for a wi-fi connection. Now I have a true wi-fi connection at home (and the 4g icon is gone from the screen). So for me this is a great work around for the problems identified in this thread.
  18. Canesfan

    Canesfan Well-Known Member


    P.P. thanks. My problem is one of not being able to connect and/or hold a WiFi connection in the larger more industrial venue rather than at home where I have no problem. 99% of my WiFi usage is not at home where I have my iPad or desk top computer for internet or other data use.

    Your described fix still might be worth a try although I'd hate to trade off my caller i.d.
  19. PickPatrick

    PickPatrick Active Member

    well as a temporary fix it might be doable.... i too like caller id
  20. gnarlyDUCK

    gnarlyDUCK Well-Known Member

    DLink users:
    I have found, sadly, that taking off mixed mode with 802.11n seems to work. This was on a Dlink DGL4500.

    I had already updated to the latest firmware, rebooted both phone and router, and tried switching to just 5Ghz band, but problems continued.
    https://plus.google.com/103629399426431225044/posts/a718Hy1DBNj
  21. Canesfan

    Canesfan Well-Known Member

    Samsung customer assistance is one of the most lame in the business. Not only did they try to double-talk what I was trying to tell them about my WiFi problems with this phone but they are in complete denial of a problem. Furthermore, they offered absolutely NO solutions. They absolutely suck.:mad:

    Next time around I'm definitely going back to an iPhone. Oh, and Apple's customer service, in contrast, is excellent.
  22. CzechPleez

    CzechPleez Well-Known Member

    The issue is well documented and not just fixated on D-Link brand devices. I spoke with Samsung guys this week and they all agree that until a patch can be issued, users with the Wi-Fi connectivity problems should switch their AP to use TKIP instead of AES.

    There are also issues using LEAP or PEAP authentication, which has no current workaround.

    Samsung is working on it and will issue an MR ASAP.
  23. wallstreet123456

    wallstreet123456 Well-Known Member

    That caller ID feature I thought was a free trial and is pay for service after that.

    Is Samsung aware of the WiFi issue? Seems from some posts here, people reach level II support and then are told to replace the phone, if that is the case Samsung is not acknowledging any issues?
  24. Canesfan

    Canesfan Well-Known Member

    With Samsung level II support telling me to contact AT&T to have them replace the phone, what do you think?

    Dealing with them is a cluster frick.
  25. Danjester

    Danjester Member

    Similar issue here. Stays connected at home (Virgin Media superhub), and elsewhere, but at my gf's apartment it keeps dropping and reconnecting to her Sky hub. This happens every couple of minutes for a while, then is fine for a random period, then starts again. Her devices do not have this issue (iPhone, iPad, Windows 7 laptop)

Share This Page