1. Download our Official Android App: Forums for Android!

xScope, a multitouch pinch zoom browser

Discussion in 'Android Apps & Games' started by xScope, Nov 23, 2009.

  1. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    Animated GIFs and javascripts are the cause and this is confirmed!
    There is a function called onPause() I overlooked. It is not a public API so I will have to hack through to use it. Stock browser and many others are not compiled against public APIs. This frustrated me a lot. For example, here is another unfortunate developer, LOL

    Issue 10282 - android - Public API for WebView.onPause and WebView.onResume - Project Hosting on Google Code

    I quickly tested a few ideas and it seems work great. I will finalize a solution and bring it to you guys tonight. So grateful and excited now. Thanks a LOT dav and the _one!

     

    Advertisement

    SprintFun and CriticalCritic like this.
  2. bill72

    bill72 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    2
    0
    5
    Hello, new to android and xscope. I like the browser, having this same issue with CPU usage. I opened huffingtonpost.com with both the stock browser and xscope, then opened task manager on epic 4g. Stock loads page then CPU usage stays at 0.00%. Xscope continues to use CPU indefinitely, bouncing back and forth from ~2% up to between ~20% - 60% or higher. There is processing constantly going on. Some other issues, I can't get some pages (such as huffingtonpost.com) to fit to screen on page load, whereas stock does this. As well, if I single finger zoom and happen to zoom over a link, the link will load. These issues might be my settings, I'm still playing around with them. Thanks for help. Bill
     
  3. bill72

    bill72 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    2
    0
    5
    I am using 6.08, see you are figuring this out. Thanks Bill
     
  4. marriedman624

    marriedman624 Member
    Rank:
    None
    Points:
    16
    Posts:
    84
    Joined:
    May 20, 2010

    May 20, 2010
    84
    7
    16
    Did this question ever get answered?
     
  5. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    Not answered. sorry.
    Not sure if an option in settings or just leave it as is. On the one hand, I do want it to be as flexible as possible. On the other hand, I have to keep setttings as simple as possible.
     
  6. CriticalCritic

    CriticalCritic Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    1,863
    Joined:
    Nov 9, 2009

    Nov 9, 2009
    1,863
    554
    213
    Cary, NC
    If a longpress on the back button isn't assigned to anything significant (I don't remember what XS6 has it set as... I never tried it) then why not set it that way and forget the settings option?
     
  7. SHO_ONE

    SHO_ONE Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    527
    Joined:
    Mar 19, 2010

    Mar 19, 2010
    527
    150
    93
    Chicago, IL
    I'm assuming you meant SHO_ONE and your welcome, I think I speak for the community when I say thats part of why we're here... to help. I had a feeling it had somthing to do with that too, so I'm glad this was brought to light.... I must admit, I'm hoping xscope get's the fixes it's needs. As someone here put it, It's the stock browser plus all the features it should have had. If / when possible fix the pinch to zoom (links being accidentally pressed when Pinch / Zooming) and Text re-flow. I don't know why xscope hangs at times and that could be another issue, but great start.... Keep it going xScope!
     
  8. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    well, currently long press will show you all history in current tab, and options to close tab and exit app.

     
  9. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    Yes you sir.
    This is great attitude! Without all of your great feedbacks, I can image I can go this far.
    Android, like xScope in some sense, is a huge beta itself. Very buggy LOL

    The thing bothered me a lot is that google doesn't play by their own rules. They use many backdoors and ugly solutions to get things done. For example, pinch-zoom. xScope was the first to bring it to the android market on Nov 23 2009, however it is not as good as what it is now. Google, on the other hand, made the pinch-zoom working on android 2.1 by adding a few new APIs. The problem is that those APIs are not public. So although I could hack through to use it, I really don't like this approach.

     
  10. marriedman624

    marriedman624 Member
    Rank:
    None
    Points:
    16
    Posts:
    84
    Joined:
    May 20, 2010

    May 20, 2010
    84
    7
    16

    Thanks for the quick reply, I understand why it wasn't answered before as I'm sure you are swamped with questions.

    So, do this mean that image downloading isn't currently available but may be down the road sometime? You are just trying to figure out how to implement it?
     
  11. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    image downloading is fine. Long click image. You will have a long list of options and remember to scroll down if necessary.
     
  12. marriedman624

    marriedman624 Member
    Rank:
    None
    Points:
    16
    Posts:
    84
    Joined:
    May 20, 2010

    May 20, 2010
    84
    7
    16
    Maybe I'm missing something.....When i long press an image, I get nothing. Do I need to change something in the settings?
     
  13. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    No you don't. It is by default.
    This is really strange as you are not the only one report this. I just randomly search some image and I can long press and see the View/Download options.
     
  14. SHO_ONE

    SHO_ONE Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    527
    Joined:
    Mar 19, 2010

    Mar 19, 2010
    527
    150
    93
    Chicago, IL
    I'm not sure if tonight's update was suppose to fix the memory usage issue; however I seem to still be experiencing the issue. On another note, it would seem the accidental pressing of links has been addressed. I can zoom with minimal issues.
     
  15. centauress

    centauress Member
    Rank:
    None
    Points:
    36
    Posts:
    93
    Joined:
    Mar 20, 2010

    Mar 20, 2010
    93
    8
    36
    Work
    On land, duh...

    Could you do this sequence and check if it works?

    Do Google image search.
    Click an image result.
    Click the 'See image full size' tab.
    Try to download the full-sized image.

    This is the sequence that catches me. I'm thinking that if the same process works for you, xScope, then it might be because of the device I'm using that is the problem - or at least the programs/drivers inside it.
     
  16. lexluthor

    lexluthor Android Expert
    Rank:
    None
    Points:
    283
    Posts:
    4,160
    Joined:
    May 15, 2010

    May 15, 2010
    4,160
    402
    283
    Long Island, NY
    Tonight's update? Is the free one not getting updates?
     
  17. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    yep. all up to date
     
    lexluthor and Cyansmoker like this.
  18. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    [​IMG]




    [​IMG]



    [​IMG]


    [​IMG]

    OK. My screenshots of each step.

     
  19. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    Just updated! (3AM)
    The problem should be solved!
    Gary
     
  20. dav1

    dav1 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Oct 2, 2010

    Oct 2, 2010
    10
    0
    15
    Now it works great .. Thanks xscope, for the great browser, and your support
     

    Attached Files:

  21. marriedman624

    marriedman624 Member
    Rank:
    None
    Points:
    16
    Posts:
    84
    Joined:
    May 20, 2010

    May 20, 2010
    84
    7
    16
    Tried this last night and when i long press i get nothing. I'm on an Evo 4G.

    I went through all the steps, just didn't want to quote of this images and clog the thread.
     
  22. mattots

    mattots Newbie
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Mar 31, 2010

    Mar 31, 2010
    25
    0
    15
    Sorry, I don't like to keep harping on about this but can anyone confirm either way if this is or isn't happening for them? At the moment I'm beginning to wonder if it's just me, but I can't quite see how that would be the case!

     
  23. binary visions

    binary visions Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    3,334
    Joined:
    May 14, 2010

    May 14, 2010
    3,334
    1,443
    413
    Yes, I can confirm that it still happens.

    If I have the browser open, and I go to another app, launch an external link, and then close that tab - the browser exits entirely instead of just closing the one tab.
     
  24. SprintFun

    SprintFun Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    1,543
    Joined:
    Mar 31, 2010

    Mar 31, 2010
    1,543
    656
    213
    Columbus, OH
    I'm on an Evo also and can confirm that when doing a google image search you cannot click on any of the pictures. You cannot even click the left and right arrows to scroll through the images. However, at the bottom where it says "searches related to:" I can click those links still.

    Edit: I can click the page numbers to scroll through the various images, but clicking the left and right arrows does nothing.
     
  25. xScope

    xScope Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    426
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    426
    55
    53
    This behavior is expected. For a tab that is initiated form external intents other than launcher, bookmark shortcuts or xScope itself, closing the tab = putting xScope in background and going back to the initiating app.

     

Share This Page

Loading...